NCTAudioLibrary2Lib

NCTAudioStudio2 ActiveX DLLs
NCTAudioLibrary2 ActiveX DLL

Version 2.2

NCTAudioLibrary2 ActiveX DLL is a DBMS for your audio files.

With NCTAudioLibrary2 you can organize audio files on your local disks.

NCTAudioLibrary2 contains the following tables:

  • Album

  • Artist

  • Detail

  • Genre

  • Playlist

NCTAudioLibrary2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioLibrary2 documentation.
NCTAudioLibrary2 was developed by NCT Company Ltd. http://www.nctsoft.com


Objects

Objects

Objects | Description
Album | This object is a table, which contains information about Albums.
Artist | This object is a table, which contains information about artists.
AudioLibrary2 | The AudioLibrary2 object organizes audio files on your local disks. It unites all the objects from this dll library.
Detail | This object is a table, which contains information about audio file details.
Genre | This object is a table, which contains information about Genres.
PlayList | This object is a table, which contains information about Play Lists.


Album

Album object

This object is a table, which contains information about Albums.


Album properties

Album properties

Property | Type | Default | Description
Name | String |  | Gets or sets the current value of the Name field.


Name property (Album)

Name property (Album)

Gets or sets the current value of the Name field.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
value | String |

See Also:

Applies to: Album


Album methods

Album methods

Method | Description
Delete | Deletes current record from the record set.
First | Sets the cursor to the first record on the record set.
GetCurrentId | Gets ID of the current record in the record set.
GetRecordCount | Gets the number of records in the record set.
Insert | Inserts record in data base, opened by DBOpen method.
IsFirst | Gets a flag if the current record is the first or not in the current record set.
IsLast | Gets a flag if the current record is the last or not in the current record set.
Last | Sets the cursor to the last record in the current record set.
Next | Sets the cursor to the next record in the current record set.
Prev | Sets the cursor to the previous record in the current record set.
Query | Sends query to data base, opened by DBOpen method.
Requery | Repeats query to data base, after applying Query method.
SetCurrentId | Sets the cursor to the current record with the given ID.
Update | Updates the changes in the record set.


Delete method

Delete method

Deletes current record from the record set.

Syntax

object.Delete()

The Delete method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

Insert | Update

Applies to: Album


First method

First method

Sets the cursor to the first record on the record set.

Syntax

object.First()

The First method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Album


GetCurrentId method

GetCurrentId method

Gets ID of the current record in the record set.

Return Type

A Long value.

Syntax

ID = object.GetCurrentId()

The GetCurrentId method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
ID | Long | ID of the current record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Album


GetRecordCount method

GetRecordCount method

Gets the number of records in the record set.

Return Type

A Long value.

Syntax

Count = object.GetRecordCount()

The GetRecordCount method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
Count | Long | Number of records.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Album


Insert method

Insert method

Inserts record in data base, opened by DBOpen method.

Syntax

object.Insert()

The Insert method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

See Also:

Delete | Update

Applies to: Album


IsFirst method

IsFirst method

Gets a flag if the current record is the first or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsFirst()

The IsFirst method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
Flag | Boolean | True if record is first, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Album


IsLast method

IsLast method

Gets a flag if the current record is the last or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsLast()

The IsLast method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
Flag | Boolean | True if record is last, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | Last | Next | Prev | SetCurrentId

Applies to: Album


Last method

Last method

Sets the cursor to the last record in the current record set.

Syntax

object.Last()

The Last method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Next | Prev | SetCurrentId

Applies to: Album


Next method

Next method

Sets the cursor to the next record in the current record set.

Syntax

object.Next()

The Next method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Prev | SetCurrentId

Applies to: Album


Prev method

Prev method

Sets the cursor to the previous record in the current record set.

Syntax

object.Prev()

The Prev method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | SetCurrentId

Applies to: Album


Query method

Query method

Sends query to data base, opened by DBOpen method.

Syntax

object.Query(SQLString As String)

The Query method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
SQLString | String | SQL request.

See Also:

Requery

Applies to: Album


Requery method

Requery method

Repeats query to data base, after applying Query method.

Syntax

object.Requery()

The Requery method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

See Also:

Query

Applies to: Album


SetCurrentId method

SetCurrentId method

Sets the cursor to the current record with the given ID.

Syntax

object.SetCurrentId(currentId As Long)

The SetCurrentId method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.
currentId | Long | ID of record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev

Applies to: Album


Update method

Update method

Updates the changes in the record set.

Syntax

object.Update()

The Update method syntax has these parts:

Part | Type | Description
object | Album | An expression evaluating to an object.

See Also:

Delete | Insert

Applies to: Album


Artist

Artist object

This object is a table, which contains information about artists.


Artist properties

Artist properties

Property | Type | Default | Description
Name | String |  | Gets or sets the current value of the Name field.


Name property (Artist)

Name property (Artist)

Gets or sets the current value of the Name field.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
value | String |

See Also:

Applies to: Artist


Artist methods

Artist methods

Method | Description
Delete | Deletes current record from the record set.
First | Sets the cursor to the first record on the record set.
GetCurrentId | Gets ID of the current record in the record set.
GetRecordCount | Gets the number of records in the record set.
Insert | Inserts record in data base, opened by DBOpen method.
IsFirst | Gets a flag if the current record is the first or not in the current record set.
IsLast | Gets a flag if the current record is the last or not in the current record set.
Last | Sets the cursor to the last record in the current record set.
Next | Sets the cursor to the next record in the current record set.
Prev | Sets the cursor to the previous record in the current record set.
Query | Sends query to data base, opened by DBOpen method.
Requery | Repeats query to data base, after applying Query method.
SetCurrentId | Sets the cursor to the current record with the given ID.
Update | Updates the changes in the record set.


Delete method

Delete method

Deletes current record from the record set.

Syntax

object.Delete()

The Delete method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

Insert | Update

Applies to: Artist


First method

First method

Sets the cursor to the first record on the record set.

Syntax

object.First()

The First method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Artist


GetCurrentId method

GetCurrentId method

Gets ID of the current record in the record set.

Return Type

A Long value.

Syntax

ID = object.GetCurrentId()

The GetCurrentId method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
ID | Long | ID of the current record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Artist


GetRecordCount method

GetRecordCount method

Gets the number of records in the record set.

Return Type

A Long value.

Syntax

Count = object.GetRecordCount()

The GetRecordCount method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
Count | Long | Number of records.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Artist


Insert method

Insert method

Inserts record in data base, opened by DBOpen method.

Syntax

object.Insert()

The Insert method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

See Also:

Delete | Update

Applies to: Artist


IsFirst method

IsFirst method

Gets a flag if the current record is the first or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsFirst()

The IsFirst method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
Flag | Boolean | True if record is first, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Artist


IsLast method

IsLast method

Gets a flag if the current record is the last or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsLast()

The IsLast method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
Flag | Boolean | True if record is last, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | Last | Next | Prev | SetCurrentId

Applies to: Artist


Last method

Last method

Sets the cursor to the last record in the current record set.

Syntax

object.Last()

The Last method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Next | Prev | SetCurrentId

Applies to: Artist


Next method

Next method

Sets the cursor to the next record in the current record set.

Syntax

object.Next()

The Next method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Prev | SetCurrentId

Applies to: Artist


Prev method

Prev method

Sets the cursor to the previous record in the current record set.

Syntax

object.Prev()

The Prev method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | SetCurrentId

Applies to: Artist


Query method

Query method

Sends query to data base, opened by DBOpen method.

Syntax

object.Query(SQLString As String)

The Query method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
SQLString | String | SQL request.

See Also:

Requery

Applies to: Artist


Requery method

Requery method

Repeats query to data base, after applying Query method.

Syntax

object.Requery()

The Requery method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

See Also:

Query

Applies to: Artist


SetCurrentId method

SetCurrentId method

Sets the cursor to the current record with the given ID.

Syntax

object.SetCurrentId(currentId As Long)

The SetCurrentId method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.
currentId | Long | ID of record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev

Applies to: Artist


Update method

Update method

Updates the changes in the record set.

Syntax

object.Update()

The Update method syntax has these parts:

Part | Type | Description
object | Artist | An expression evaluating to an object.

See Also:

Delete | Insert

Applies to: Artist


AudioLibrary2

AudioLibrary2 object

The AudioLibrary2 object organizes audio files on your local disks. It unites all the objects from this dll library.


AudioLibrary properties

AudioLibrary2 properties

Property | Type | Default | Description
Album | Album |  | Read-only property that returns a reference to Album object in NCTAudioLibrary2 control.
Artist | Artist |  | Read-only property that returns a reference to Artist table in NCTAudioLibrary2 control.
Detail | Detail |  | Read-only property that returns a reference to Detail object in NCTAudioLibrary2 control.
Genre | Genre |  | Read-only property that returns a reference to Genre object in NCTAudioLibrary2 control.
PlayList | PlayList |  | Read-only property that returns a reference to PlayList object in NCTAudioLibrary2 control.


Album property (AudioLibrary2)

Album property (AudioLibrary2)

Read-only property that returns a reference to Album object in NCTAudioLibrary2 control.

Property type

A Album value.

Syntax

object.Album [= value]

The Album property syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
value | Album |

See Also:

Artist | Detail | Genre | PlayList

Applies to: AudioLibrary2


Artist property (AudioLibrary2)

Artist property (AudioLibrary2)

Read-only property that returns a reference to Artist table in NCTAudioLibrary2 control.

Property type

A Artist value.

Syntax

object.Artist [= value]

The Artist property syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
value | Artist |

See Also:

Album | Detail | Genre | PlayList

Applies to: AudioLibrary2


Detail property (AudioLibrary2)

Detail property (AudioLibrary2)

Read-only property that returns a reference to Detail object in NCTAudioLibrary2 control.

Property type

A Detail value.

Syntax

object.Detail [= value]

The Detail property syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
value | Detail |

See Also:

Album | Artist | Genre | PlayList

Applies to: AudioLibrary2


Genre property (AudioLibrary2)

Genre property (AudioLibrary2)

Read-only property that returns a reference to Genre object in NCTAudioLibrary2 control.

Property type

A Genre value.

Syntax

object.Genre [= value]

The Genre property syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
value | Genre |

See Also:

Album | Artist | Detail | PlayList

Applies to: AudioLibrary2


PlayList property (AudioLibrary2)

PlayList property (AudioLibrary2)

Read-only property that returns a reference to PlayList object in NCTAudioLibrary2 control.

Property type

A PlayList value.

Syntax

object.PlayList [= value]

The PlayList property syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
value | PlayList |

See Also:

Album | Artist | Detail | Genre

Applies to: AudioLibrary2


AudioLibrary methods

AudioLibrary2 methods

Method | Description
DBClose | Closes database session, opened by DBOpen method.
DBCommit | Commits current database transaction.
DBOpen | Opens data base.
DBRollback | Rollbacks transaction.
InsertFromFile | Inserts information about audio file to data base, opened by DBOpen method.
InsertFromFolder | Inserts information about audio files from specific folder to data base, opened by DBOpen method.
Register | Enters user name and registration password to disable About window.


DBClose method

DBClose method

Closes database session, opened by DBOpen method.

Syntax

object.DBClose()

The DBClose method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.

See Also:

DBCommit | DBOpen | DBRollback

Applies to: AudioLibrary2


DBCommit method

DBCommit method

Commits current database transaction.

Syntax

object.DBCommit()

The DBCommit method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.

See Also:

DBClose | DBOpen | DBRollback

Applies to: AudioLibrary2


DBOpen method

DBOpen method

Opens data base.

Syntax

object.DBOpen(fileName As String)

The DBOpen method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
fileName | String | Pathname to the data base file.

See Also:

DBClose | DBCommit | DBRollback

Applies to: AudioLibrary2


DBRollback method

DBRollback method

Rollbacks transaction.

Syntax

object.DBRollback()

The DBRollback method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.

See Also:

DBClose | DBCommit | DBOpen

Applies to: AudioLibrary2


InsertFromFile method

InsertFromFile method

Inserts information about audio file to data base, opened by DBOpen method.

Return Type

A Boolean value.

Syntax

Code = object.InsertFromFile(fileName As String)

The InsertFromFile method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
fileName | String | Pathname of audio file.
Code | Boolean | True if method is successful, otherwise False.

See Also:

InsertFromFolder

Applies to: AudioLibrary2


InsertFromFolder method

InsertFromFolder method

Inserts information about audio files from specific folder to data base, opened by DBOpen method.

Return Type

A Long value.

Syntax

Code = object.InsertFromFolder(FolderName As String, SubFolder As Boolean)

The InsertFromFolder method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
FolderName | String | Pathname of folder.
SubFolder | Boolean | This is a flag indicating if the FolderName is a subfolder or not. True if FolderName is a subfolder, otherwise - False.
Code | Long | True if method is successful, otherwise False.

See Also:

InsertFromFile

Applies to: AudioLibrary2


Register method

Register method

Enters user name and registration password to disable About window.

Syntax

object.Register(strUser As String, strPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioLibrary2 | An expression evaluating to an object.
strUser | String | User name. You get a registration user name after the registration.
strPassword | String | Password string. You get a registration password after the registration.

See Also:

Applies to: AudioLibrary2


Detail

Detail object

This object is a table, which contains information about audio file details.


Detail properties

Detail properties

Property | Type | Default | Description
AlbumName | String |  | Gets or sets the current value of the AlbumName field in Detail table.
ArtistName | String |  | Gets or sets the current value of the ArtistName field in Detail table.
AudioType | Long |  | Gets or sets the current value of the AudioType field in Detail table.
Bitrate | Long |  | Gets or sets the current value of the Bitrate field in Detail table.
BitsPerSample | Long |  | Gets or sets the current value of the BitsPerSample field in Detail table.
Channels | Long |  | Gets or sets the current value of the Channels field in Detail table.
Comments | String |  | Gets or sets the current value of the Comments field in Detail table.
Copyright | String |  | Gets or sets the current value of the Copyright field in Detail table.
Duration | Long |  | Gets or sets the current value of the Duration field in Detail table.
File | String |  | Gets or sets the current value of the File field in Detail table.
FolderName | String |  | Gets or sets the current value of the FolderName field in Detail table.
FormatString | String |  | Gets or sets the current value of the FormatString field in Detail table.
FormatTag | Long |  | Gets or sets the current value of the FormatTag field in Detail table.
Frequency | Long |  | Gets or sets the current value of the Frequency field in Detail table.
GenreName | String |  | Gets or sets the current value of the GenreName field in Detail table.
PlayCount | Long |  | Gets or sets the current value of the PlayCount field in Detail table.
Protected | Long |  | Gets or sets the current value of the Protected field in Detail table.
Rating | Long |  | Gets or sets the current value of the Rating field in Detail table.
Samples | Long |  | Gets or sets the current value of the Samples field in Detail table.
Size | Long |  | Gets or sets the current value of the Size field in Detail table.
Title | String |  | Gets or sets the current value of the Title field in Detail table.
Year | Long |  | Gets or sets the current value of the Year field in Detail table.


AlbumName property (Detail)

AlbumName property (Detail)

Gets or sets the current value of the AlbumName field in Detail table.

Property type

A String value.

Syntax

object.AlbumName [= value]

The AlbumName property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String | String with album name.

Remarks:

See Also:

ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


ArtistName property (Detail)

ArtistName property (Detail)

Gets or sets the current value of the ArtistName field in Detail table.

Property type

A String value.

Syntax

object.ArtistName [= value]

The ArtistName property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String | String with artist name.

See Also:

AlbumName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


AudioType property (Detail)

AudioType property (Detail)

Gets or sets the current value of the AudioType field in Detail table.

Property type

A Long value.

Syntax

object.AudioType [= value]

The AudioType property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object of type .
value | Long | Can accept the following values: 0 - the audio file has WAV type, 1 - the audio file has MP3 type.

See Also:

AlbumName | ArtistName | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Bitrate property (Detail)

Bitrate property (Detail)

Gets or sets the current value of the Bitrate field in Detail table.

Property type

A Long value.

Syntax

object.Bitrate [= value]

The Bitrate property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long | Bitrate is in bps (bits per seconds).

See Also:

AlbumName | ArtistName | AudioType | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


BitsPerSample property (Detail)

BitsPerSample property (Detail)

Gets or sets the current value of the BitsPerSample field in Detail table.

Property type

A Long value.

Syntax

object.BitsPerSample [= value]

The BitsPerSample property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Channels property (Detail)

Channels property (Detail)

Gets or sets the current value of the Channels field in Detail table.

Property type

A Long value.

Syntax

object.Channels [= value]

The Channels property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long | Can accept the following values: 1 - audio file has type mono, 2 - audio file has type stereo.

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Comments property (Detail)

Comments property (Detail)

Gets or sets the current value of the Comments field in Detail table.

Property type

A String value.

Syntax

object.Comments [= value]

The Comments property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Copyright property (Detail)

Copyright property (Detail)

Gets or sets the current value of the Copyright field in Detail table.

Property type

A String value.

Syntax

object.Copyright [= value]

The Copyright property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Duration property (Detail)

Duration property (Detail)

Gets or sets the current value of the Duration field in Detail table.

Property type

A Long value.

Syntax

object.Duration [= value]

The Duration property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long | Duration is in milliseconds.

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


File property (Detail)

File property (Detail)

Gets or sets the current value of the File field in Detail table.

Property type

A String value.

Syntax

object.File [= value]

The File property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | FolderName | FormatString | FormatTag | Frequency | GenreName | Rating | Samples | Size | Title | Year

Applies to: Detail


FolderName property (Detail)

FolderName property (Detail)

Gets or sets the current value of the FolderName field in Detail table.

Property type

A String value.

Syntax

object.FolderName [= value]

The FolderName property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


FormatString property (Detail)

FormatString property (Detail)

Gets or sets the current value of the FormatString field in Detail table.

Property type

A String value.

Syntax

object.FormatString [= value]

The FormatString property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


FormatTag property (Detail)

FormatTag property (Detail)

Gets or sets the current value of the FormatTag field in Detail table.

Property type

A Long value.

Syntax

object.FormatTag [= value]

The FormatTag property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Frequency property (Detail)

Frequency property (Detail)

Gets or sets the current value of the Frequency field in Detail table.

Property type

A Long value.

Syntax

object.Frequency [= value]

The Frequency property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long | Frequency is in Hz.

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | GenreName | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


GenreName property (Detail)

GenreName property (Detail)

Gets or sets the current value of the GenreName field in Detail table.

Property type

A String value.

Syntax

object.GenreName [= value]

The GenreName property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | PlayCount | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


PlayCount property (Detail)

PlayCount property (Detail)

Gets or sets the current value of the PlayCount field in Detail table.

Property type

A Long value.

Syntax

object.PlayCount [= value]

The PlayCount property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | Protected | Rating | Samples | Size | Title | Year

Applies to: Detail


Protected property (Detail)

Protected property (Detail)

Gets or sets the current value of the Protected field in Detail table.

Property type

A Long value.

Syntax

object.Protected [= value]

The Protected property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Rating | Samples | Size | Title | Year

Applies to: Detail


Rating property (Detail)

Rating property (Detail)

Gets or sets the current value of the Rating field in Detail table.

Property type

A Long value.

Syntax

object.Rating [= value]

The Rating property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Samples | Size | Title | Year

Applies to: Detail


Samples property (Detail)

Samples property (Detail)

Gets or sets the current value of the Samples field in Detail table.

Property type

A Long value.

Syntax

object.Samples [= value]

The Samples property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object of type .
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Size | Title | Year

Applies to: Detail


Size property (Detail)

Size property (Detail)

Gets or sets the current value of the Size field in Detail table.

Property type

A Long value.

Syntax

object.Size [= value]

The Size property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long | Size is in bytes.

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Title | Year

Applies to: Detail


Title property (Detail)

Title property (Detail)

Gets or sets the current value of the Title field in Detail table.

Property type

A String value.

Syntax

object.Title [= value]

The Title property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | String |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Year

Applies to: Detail


Year property (Detail)

Year property (Detail)

Gets or sets the current value of the Year field in Detail table.

Property type

A Long value.

Syntax

object.Year [= value]

The Year property syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
value | Long |

See Also:

AlbumName | ArtistName | AudioType | Bitrate | BitsPerSample | Channels | Comments | Copyright | Duration | File | FolderName | FormatString | FormatTag | Frequency | GenreName | PlayCount | Protected | Rating | Samples | Size | Title

Applies to: Detail


Detail methods

Detail methods

Method | Description
Delete | Deletes current record from the record set.
First | Sets the cursor to the first record on the record set.
GetCurrentId | Gets ID of the current record in the record set.
GetRecordCount | Gets the number of records in the record set.
Insert | Inserts record in data base, opened by DBOpen method.
InsertToPlayList | Inserts to the current play list.
IsFirst | Gets a flag if the current record is the first or not in the current record set.
IsLast | Gets a flag if the current record is the last or not in the current record set.
Last | Sets the cursor to the last record in the current record set.
Next | Sets the cursor to the next record in the current record set.
Prev | Sets the cursor to the previous record in the current record set.
Query | Sends query to data base, opened by DBOpen method.
RemoveFromPlayList | Removes the current record from the current play list.
Requery | Repeats query to data base, after applying Query method.
SetCurrentId | Sets the cursor to the current record with the given ID.
Update | Updates the changes in the record set.


Delete method

Delete method

Deletes current record from the record set.

Syntax

object.Delete()

The Delete method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

Insert | Update

Applies to: Detail


First method

First method

Sets the cursor to the first record on the record set.

Syntax

object.First()

The First method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Detail


GetCurrentId method

GetCurrentId method

Gets ID of the current record in the record set.

Return Type

A Long value.

Syntax

ID = object.GetCurrentId()

The GetCurrentId method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
ID | Long | ID of the current record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Detail


GetRecordCount method

GetRecordCount method

Gets the number of records in the record set.

Return Type

A Long value.

Syntax

Count = object.GetRecordCount

The GetRecordCount method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
Count | Long | Number of records.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Detail


Insert method

Insert method

Inserts record in data base, opened by DBOpen method.

Syntax

object.Insert()

The Insert method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

See Also:

Delete | Update

Applies to: Detail


InsertToPlayList method

InsertToPlayList method

Inserts to the current play list.

Syntax

object.InsertToPlayList(PlayList As String)

The InsertToPlayList method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
PlayList | String | Play list.

See Also:

RemoveFromPlayList

Applies to: Detail


IsFirst method

IsFirst method

Gets a flag if the current record is the first or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsFirst()

The IsFirst method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
Flag | Boolean | True if record is first, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Detail


IsLast method

IsLast method

Gets a flag if the current record is the last or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsLast()

The IsLast method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
Flag | Boolean | True if record is last, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | Last | Next | Prev | SetCurrentId

Applies to: Detail


Last method

Last method

Sets the cursor to the last record in the current record set.

Syntax

object.Last()

The Last method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Next | Prev | SetCurrentId

Applies to: Detail


Next method

Next method

Sets the cursor to the next record in the current record set.

Syntax

object.Next()

The Next method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Prev | SetCurrentId

Applies to: Detail


Prev method

Prev method

Sets the cursor to the previous record in the current record set.

Syntax

object.Prev()

The Prev method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | SetCurrentId

Applies to: Detail


Query method

Query method

Sends query to data base, opened by DBOpen method.

Syntax

object.Query(SQLString As String)

The Query method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
SQLString | String | SQL request.

See Also:

Requery

Applies to: Detail


RemoveFromPlayList method

RemoveFromPlayList method

Removes the current record from the current play list.

Syntax

object.RemoveFromPlayList(PlayList As String)

The RemoveFromPlayList method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object of type .
PlayList | String | Play list.

See Also:

InsertToPlayList

Applies to: Detail


Requery method

Requery method

Repeats query to data base, after applying Query method.

Syntax

object.Requery()

The Requery method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

See Also:

Query

Applies to: Detail


SetCurrentId method

SetCurrentId method

Sets the cursor to the current record with the given ID.

Syntax

object.SetCurrentId(currentId As Long)

The SetCurrentId method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.
currentId | Long | ID of record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev

Applies to: Detail


Update method

Update method

Updates the changes in the record set.

Syntax

object.Update()

The Update method syntax has these parts:

Part | Type | Description
object | Detail | An expression evaluating to an object.

See Also:

Delete | Insert

Applies to: Detail


Genre

Genre object

This object is a table, which contains information about Genres.


Genre properties

Genre properties

Property | Type | Default | Description
Name | String |  | Gets or sets the current value of the Name field.


Name property (Genre)

Name property (Genre)

Gets or sets the current value of the Name field.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
value | String |

See Also:

Applies to: Genre


Genre methods

Genre methods

Method | Description
Delete | Deletes current record from the record set.
First | Sets the cursor to the first record on the record set.
GetCurrentId | Gets ID of the current record in the record set.
GetRecordCount | Gets the number of records in the record set.
Insert | Inserts record in data base, opened by DBOpen method.
IsFirst | Gets a flag if the current record is the first or not in the current record set.
IsLast | Gets a flag if the current record is the last or not in the current record set.
Last | Sets the cursor to the last record in the current record set.
Next | Sets the cursor to the next record in the current record set.
Prev | Sets the cursor to the previous record in the current record set.
Query | Sends query to data base, opened by DBOpen method.
Requery | Repeats query to data base, after applying Query method.
SetCurrentId | Sets the cursor to the current record with the given ID.
Update | Updates the changes in the record set.


Delete method

Delete method

Deletes current record from the record set.

Syntax

object.Delete()

The Delete method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

Insert | Update

Applies to: Genre


First method

First method

Sets the cursor to the first record on the record set.

Syntax

object.First()

The First method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Genre


GetCurrentId method

GetCurrentId method

Gets ID of the current record in the record set.

Return Type

A Long value.

Syntax

ID = object.GetCurrentId()

The GetCurrentId method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
ID | Long | ID of the current record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Genre


GetRecordCount method

GetRecordCount method

Gets the number of records in the record set.

Return Type

A Long value.

Syntax

Count = object.GetRecordCount()

The GetRecordCount method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
Count | Long | Number of records.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Genre


Insert method

Insert method

Inserts record in data base, opened by DBOpen method.

Syntax

object.Insert()

The Insert method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

See Also:

Delete | Update

Applies to: Genre


IsFirst method

IsFirst method

Gets a flag if the current record is the first or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsFirst()

The IsFirst method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
Flag | Boolean | True if record is first, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsLast | Last | Next | Prev | SetCurrentId

Applies to: Genre


IsLast method

IsLast method

Gets a flag if the current record is the last or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsLast()

The IsLast method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
Flag | Boolean | True if record is last, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | Last | Next | Prev | SetCurrentId

Applies to: Genre


Last method

Last method

Sets the cursor to the last record in the current record set.

Syntax

object.Last()

The Last method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Next | Prev | SetCurrentId

Applies to: Genre


Next method

Next method

Sets the cursor to the next record in the current record set.

Syntax

object.Next()

The Next method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Prev | SetCurrentId

Applies to: Genre


Prev method

Prev method

Sets the cursor to the previous record in the current record set.

Syntax

object.Prev()

The Prev method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | SetCurrentId

Applies to: Genre


Query method

Query method

Sends query to data base, opened by DBOpen method.

Syntax

object.Query(SQLString As String)

The Query method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
SQLString | String | SQL request.

See Also:

Requery

Applies to: Genre


Requery method

Requery method

Repeats query to data base, after applying Query method.

Syntax

object.Requery()

The Requery method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

See Also:

Query

Applies to: Genre


SetCurrentId method

SetCurrentId method

Sets the cursor to the current record with the given ID.

Syntax

object.SetCurrentId(currentId As Long)

The SetCurrentId method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.
currentId | Long | ID of record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev

Applies to: Genre


Update method

Update method

Updates the changes in the record set.

Syntax

object.Update()

The Update method syntax has these parts:

Part | Type | Description
object | Genre | An expression evaluating to an object.

See Also:

Delete | Insert

Applies to: Genre


PlayList

PlayList object

This object is a table, which contains information about Play Lists.


PlayList properties

PlayList properties

Property | Type | Default | Description
Name | String |  | Gets or sets the current value of the Name field.


Name property (PlayList)

Name property (PlayList)

Gets or sets the current value of the Name field.

Property type

A String value.

Syntax

object.Name [= value]

The Name property syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
value | String |

See Also:

Applies to: PlayList


PlayList methods

PlayList methods

Method | Description
Delete | Deletes current record from the record set.
First | Sets the cursor to the first record on the record set.
GetCurrentId | Gets ID of the current record in the record set.
GetRecordCount | Gets the number of records in the record set.
Insert | Inserts record in data base, opened by DBOpen method.
IsFirst | Gets a flag if the current record is the first or not in the current record set.
IsLast | Gets a flag if the current record is the last or not in the current record set.
Last | Sets the cursor to the last record in the current record set.
Next | Sets the cursor to the next record in the current record set.
Prev | Sets the cursor to the previous record in the current record set.
Query | Sends query to data base, opened by DBOpen method.
Requery | Repeats query to data base, after applying Query method.
SetCurrentId | Sets the cursor to the current record with the given ID.
Update | Updates the changes in the record set.


Delete method

Delete method

Deletes current record from the record set.

Syntax

object.Delete()

The Delete method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

Insert | Update

Applies to: PlayList


First method

First method

Sets the cursor to the first record on the record set.

Syntax

object.First()

The First method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: PlayList


GetCurrentId method

GetCurrentId method

Gets ID of the current record in the record set.

Return Type

A Long value.

Syntax

ID = object.GetCurrentId()

The GetCurrentId method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
ID | Long | ID of the current record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetRecordCount | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: PlayList


GetRecordCount method

GetRecordCount method

Gets the number of records in the record set.

Return Type

A Long value.

Syntax

Count = object.GetRecordCount()

The GetRecordCount method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
Count | Long | Number of records.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | IsFirst | IsLast | Last | Next | Prev | SetCurrentId

Applies to: PlayList


Insert method

Insert method

Inserts record in data base, opened by DBOpen method.

Syntax

object.Insert()

The Insert method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

See Also:

Delete | Update

Applies to: PlayList


IsFirst method

IsFirst method

Gets a flag if the current record is the first or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsFirst()

The IsFirst method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
Flag | Boolean | True if record is first, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsLast | Last | Next | Prev | SetCurrentId

Applies to: PlayList


IsLast method

IsLast method

Gets a flag if the current record is the last or not in the current record set.

Return Type

A Boolean value.

Syntax

Flag = object.IsLast()

The IsLast method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
Flag | Boolean | True if record is last, otherwise False.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | Last | Next | Prev | SetCurrentId

Applies to: PlayList


Last method

Last method

Sets the cursor to the last record in the current record set.

Syntax

object.Last()

The Last method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Next | Prev | SetCurrentId

Applies to: PlayList


Next method

Next method

Sets the cursor to the next record in the current record set.

Syntax

object.Next()

The Next method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Prev | SetCurrentId

Applies to: PlayList


Prev method

Prev method

Sets the cursor to the previous record in the current record set.

Syntax

object.Prev()

The Prev method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | SetCurrentId

Applies to: PlayList


Query method

Query method

Sends query to data base, opened by DBOpen method.

Syntax

object.Query(SQLString As String)

The Query method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
SQLString | String | SQL request.

See Also:

Requery

Applies to: PlayList


Requery method

Requery method

Repeats query to data base, after applying Query method.

Syntax

object.Requery()

The Requery method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

See Also:

Query

Applies to: PlayList


SetCurrentId method

SetCurrentId method

Sets the cursor to the current record with the given ID.

Syntax

object.SetCurrentId(currentId As Long)

The SetCurrentId method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.
currentId | Long | ID of record.

Remarks:

This method can be applied only after Query or Requery methods.

See Also:

First | GetCurrentId | GetRecordCount | IsFirst | IsLast | Last | Next | Prev

Applies to: PlayList


Update method

Update method

Updates the changes in the record set.

Syntax

object.Update()

The Update method syntax has these parts:

Part | Type | Description
object | PlayList | An expression evaluating to an object.

See Also:

Delete | Insert

Applies to: PlayList


NCTAudioLibrary2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioLibrary2 ActiveX DLL is a DBMS for your audio files.

With NCTAudioLibrary2 you can organize audio files at your local disks.

NCTAudioLibrary2 contains the following tables:

  • Album

  • Artist

  • Detail

  • Genre

  • Playlist

NCTAudioLibrary2 is a part of the NCTAudioStudio2 package.